HOME     MENU     SEARCH     NEWSLETTER    
NEWS & INFORMATION FOR TECHNOLOGY PURCHASERS. UPDATED ABOUT A MINUTE AGO.
You are here: Home / Linux/Open Source / OpenSSL Patches 7 Security Flaws
82% of the Fortune 500
Use BMC for innovative solutions & competitive business advantage.
Contact BMC to learn more.
OpenSSL Patches 7 Security Flaws -- 2 Critical
OpenSSL Patches 7 Security Flaws -- 2 Critical
By Linda Rosencrance / NewsFactor Network Like this on Facebook Tweet this Link thison Linkedin Link this on Google Plus
PUBLISHED:
JUNE
05
2014
If there is any good news from the discovery of the Heartbleed bug that affects OpenSSL, it’s this: security analysts are keeping a closer watch on OpenSSL. And their efforts have paid off. The open-source OpenSSL Project today released a security update that fixes seven vulnerabilities, including two that have been rated critical by the SANS Internet Storm Center.

The first critical flaw is the SSL/TLS MiTM flaw (CVE-2014-0224). “An attacker using a carefully crafted handshake can force the use of weak keying material in OpenSSL SSL/TLS clients and servers,” according to the OpenSSL team's update. “This can be exploited by a man-in-the-middle (MiTM) attack where the attacker can decrypt and modify traffic from the attacked client and server.”

Around for 16 Years

The flaw was discovered by researcher Masashi Kikuchi of Lepidum Co. Ltd., who noted in a blog post that it had been around for over 16 years -- since the very first release of OpenSSL.

“The biggest reason why the bug hasn’t been found for over 16 years is that code reviews were insufficient, especially from experts who had experiences with TLS/SSL implementation,” he said in the post. “If the reviewers had enough experiences, they should have verified OpenSSL code in the same way they do their own code. They could have detected the problem.”

The OpenSSL team said the MiTM attack can only be performed if both the client and the server are vulnerable. OpenSSL clients are vulnerable in all versions of OpenSSL, while servers are only known to be vulnerable in OpenSSL 1.0.1 and 1.0.2-beta1. Users of OpenSSL servers earlier than 1.0.1 should upgrade as a precaution.

Critical Flaw #2

The other OpenSSL vulnerability rated as critical by the SANS Internet Storm Center (ISC) is for the flaw identified as CVE-2014-0195. It is a Datagram Transport Layer Security (DTLS) invalid fragment vulnerability that was first reported to the OpenSSL Project on April 23.

“A buffer overrun attack can be triggered by sending invalid DTLS fragments to an OpenSSL DTLS client or server,” according to the OpenSSL advisory. “This is potentially exploitable to run arbitrary code on a vulnerable client or server. Only applications using OpenSSL as a DTLS client or server affected.”

Another DTLS Flaw and More

DTLS can wreak even more havoc because it’s behind the CVE-2014-0221 vulnerability, which is a DTLS handshake recursion flaw -- rated important by SANS ISC. “By sending an invalid DTLS handshake to an OpenSSL DTLS client, the code can be made to recurse, eventually crashing in a DoS (deinal-of-service) attack,” according to the OpenSSL update. “Only applications using OpenSSL as a DTLS client are affected.”

Another vulnerability rated important by SANS ISC is SSL_MODE_RELEASE_BUFFERS NULL pointer dereference (CVE-2014-0198). “A flaw in the do_ssl3_write function can allow remote attackers to cause a denial of service via a NULL pointer dereference,” the advisory noted. “This flaw only affects OpenSSL 1.0.0 and 1.0.1 where SSL_MODE_RELEASE_BUFFERS is enabled, which is not the default and not common.”

The SSL_MODE_RELEASE_BUFFERS session injection or denial of service flaw (CVE-2010-5298) is a race condition in the ssl3_read_bytes function that can allow remote attackers to inject data across sessions or cause a denial of service. “This flaw only affects multithreaded applications using OpenSSL 1.0.0 and 1.0.1, where SSL_MODE_RELEASE_BUFFERS is enabled, which is not the default and not common,” according to the OpenSSL team.

The OpenSSL Project is also providing patches for the CVE-2014-3470 vulnerability, which is an Anonymous Elliptic Curve Diffie Hellman (ECDH) DoS problem, and the CVE-2014-0076 flaw.

To mitigate the risks of these vulnerabilities, IT managers should ensure they patch their Linux systems as soon as possible.

Tell Us What You Think
Comment:

Name:

Linus:
Posted: 2014-06-09 @ 10:25am PT
If you are running Windows servers, you have bigger problems.

n/a:
Posted: 2014-06-05 @ 6:30pm PT
OpenSSL is a dead end. LibreSSL from the OpenBSD project is a hope for a better future.

Ezra Taylor:
Posted: 2014-06-05 @ 5:44pm PT
How do we know if we are using Openssl with DTLS?

Libstein:
Posted: 2014-06-05 @ 5:18pm PT
Stunning. Such security protocols should be tested against the best hackers in the world before release. If internet fraud carried a mandatory 20 year sentence, we could let all the pot smokers out to make room for the guys who steal money on the internet.

MikeOnline:
Posted: 2014-06-05 @ 3:56pm PT
"IT managers should ensure they patch their Linux systems"

OpenSSL is available for Windows too, and is bundled or embedded within numerous client and server applications. Patching Linux systems is insufficient.

Like Us on FacebookFollow Us on Twitter
TOP STORIES NOW
MAY INTEREST YOU
Neustar, Inc. (NYSE: NSR) is a trusted, neutral provider of real-time information and analysis to the Internet, telecommunications, information services, financial services, retail, media and advertising sectors. Neustar applies its advanced, secure technologies in location, identification, and evaluation to help its customers promote and protect their businesses. More information is available at www.neustar.biz.
MORE IN LINUX/OPEN SOURCE
Product Information and Resources for Technology You Can Use To Boost Your Business
© Copyright 2014 NewsFactor Network, Inc. All rights reserved. Member of Accuserve Ad Network.